登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

herb

喜欢写博,喜欢安静,喜欢挑战!

 
 
 

日志

 
 

drdb加载模块失败  

2013-12-13 16:53:47|  分类: opensoft |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

大多数情况下这是由于系统默认的内核并不支持***模块,所以要更新内核


先看看系统的内核版本

# uname -r            (目前的版本)
2.6.32-279.el6.x86_64


下面以安装drbd模块为例进行说明
正确安装drbd模块后,使用modprobe进行加载
# modprobe drbd
FATAL: Module drbd not found.
出现如上错误


原因:这是因为系统默认的内核并不支持此模块,所以需要更新内核
更新内核的方法:


可以用 yum install kernel* 方式来更新。
如果你要节约点时间的话可以只更新一下的几个包:
            kernel-devel
            kernel
            kernel-headers

更新后,记得要重新启动操作系统!!!


重启系统后再次使用命令查看,此时的内核版本变为
# uname -r
2.6.32-358.11.1.el6.x86_64


此时再次尝试加载模块drbd


# depmod
说明:在编译并准备好一个Linux内核加载模块后,modprobe前必须先执行命令depmod,此命令会生成新的modules.dep。


# modprobe drbd
此时没有报错,查看是否加载成功
# lsmod |grep drbd
drbd                  325658  0
libcrc32c               1246  1 drbd


从上可以看出,drbd模块已成功被执行

  评论这张
 
阅读(4811)| 评论(1)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018